# io.jenkins.plugins:warnings-ng (Maven) vulnerabilities

7 known vulnerabilities, with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://central.sonatype.com/artifact/io.jenkins.plugins/warnings-ng

## Advisories (7)

### [CVE-2023-46651](https://cve.now/CVE-2023-46651): Jenkins Warnings Plugin 10.5.0 and earlier does not set the appropriate context for credentials lookup, allowing attackers with…

- Severity: Unrated
- Published: Oct 25, 2023
- Affected: from 10.5.0, fixed in 10.5.1; fixed in 10.4.1.

### [CVE-2022-23107](https://cve.now/CVE-2022-23107): Jenkins Warnings Next Generation Plugin 9.10.2 and earlier does not restrict the name of a file when configuring custom ID, allowing…

- Severity: Unrated
- Published: Jan 12, 2022
- Affected: from 9.8.0, fixed in 9.10.3; from 9.6.0, fixed in 9.7.1; from 9.1.0, fixed in 9.5.2; fixed in 9.0.2.

### [CVE-2021-21626](https://cve.now/CVE-2021-21626): Jenkins Warnings Next Generation Plugin 8.4.4 and earlier does not perform a permission check in methods implementing form validation…

- Severity: Unrated
- Published: Mar 18, 2021
- Affected: fixed in 8.5.0.

### [CVE-2019-10326](https://cve.now/CVE-2019-10326): A cross-site request forgery vulnerability in Jenkins Warnings NG Plugin 5.0.0 and earlier allowed attackers to reset warning counts for…

- Severity: Unrated
- Published: May 31, 2019
- Affected: fixed in 5.1.0.

### [CVE-2019-10325](https://cve.now/CVE-2019-10325): A cross-site scripting vulnerability in Jenkins Warnings NG Plugin 5.0.0 and earlier allowed attacker with Job/Configure permission to…

- Severity: Unrated
- Published: May 31, 2019
- Affected: fixed in 5.1.0.

### [CVE-2019-1003023](https://cve.now/CVE-2019-1003023): A cross-site scripting vulnerability exists in Jenkins Warnings Next Generation Plugin 1.0.1 and earlier in…

- Severity: Unrated
- Published: Feb 6, 2019
- Affected: fixed in 2.0.0.

### [CVE-2019-1003008](https://cve.now/CVE-2019-1003008): A cross-site request forgery vulnerability exists in Jenkins Warnings Next Generation Plugin 2.1.1 and earlier in…

- Severity: Unrated
- Published: Feb 6, 2019
- Affected: through 2.1.1.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/maven/io.jenkins.plugins:warnings-ng
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
