Skip to main content
← Maven

edu.stanford.nlp:stanford-corenlp

5 known vulnerabilities (1 critical, 1 high, 2 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
5 · 1 critical, 1 high, 2 medium
Registry
Maven Central

Advisories 5

  • An Incorrect Access Control vulnerability exists in CoreNLP 4.3.2 via the classifier in NERServlet.java (lines 158 and 159).

    Affected: fixed in 4.4.0.

  • CVE-2022-0239Medium 4.7

    Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp

    Affected: fixed in 4.4.0.

  • CVE-2022-0198Medium 6.1

    Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp

    Affected: through 4.3.2.

  • Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp

    Affected: fixed in 4.3.1.

  • CVE-2021-3878Critical 9.8

    Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp

    Affected: fixed in 4.3.1.