# com.shopizer:shopizer (Maven) vulnerabilities

5 known vulnerabilities (1 critical, 2 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: 2.16.0 (Dec 27, 2020): affected by 5 advisories
- Newest unaffected release: Every release is affected by at least one advisory
- Dependents: 0
- Releases: 1 since 2.16.0 (Dec 27, 2020)
- Registry: https://central.sonatype.com/artifact/com.shopizer/shopizer
- Releases read: Nov 8, 2026

## Version timeline

Affected versions per advisory, in version order:

- CVE-2026-36767: 2.16.0 (through the newest release)
- CVE-2026-36766: 2.16.0 (through the newest release)
- CVE-2022-23059: 2.16.0 (through the newest release)
- CVE-2021-33561: 2.16.0 (through the newest release)
- CVE-2021-33562: 2.16.0 (through the newest release)

## Advisories (5)

### [CVE-2026-36767](https://cve.now/CVE-2026-36767): A path traversal vulnerability in the /content/images/add endpoint of shopizer v3.2.5 allows attackers write arbitrary files to any…

- Severity: Critical 10.0
- Published: Apr 30, 2026
- Affected: through 2.16.0.
- No fix released. The latest release, 2.16.0, is still affected.

### [CVE-2026-36766](https://cve.now/CVE-2026-36766): Multiple authenticated cross-site scripting (XSS) vulnerabilities in the XssHttpServletRequestWrapper class of shopizer v3.2.5 allows…

- Severity: Medium 5.4
- Published: Apr 30, 2026
- Affected: through 2.16.0.
- No fix released. The latest release, 2.16.0, is still affected.

### [CVE-2022-23059](https://cve.now/CVE-2022-23059): Shopizer - Stored XSS in Manage Images

- Severity: Medium 4.8
- Published: Mar 29, 2022
- Affected: from 2.0.2, fixed in 3.0.0.
- No fix released. The advisory names 3.0.0 as the fix, which the registry doesn't have yet. The latest release, 2.16.0, is still affected.

### [CVE-2021-33561](https://cve.now/CVE-2021-33561): A stored cross-site scripting (XSS) vulnerability in Shopizer before 2.17.0 allows remote attackers to inject arbitrary web script or HTML…

- Severity: Unrated
- Published: May 24, 2021
- Affected: fixed in 2.17.0.
- No fix released. The advisory names 2.17.0 as the fix, which the registry doesn't have yet. The latest release, 2.16.0, is still affected.

### [CVE-2021-33562](https://cve.now/CVE-2021-33562): A reflected cross-site scripting (XSS) vulnerability in Shopizer before 2.17.0 allows remote attackers to inject arbitrary web script or…

- Severity: Unrated
- Published: May 24, 2021
- Affected: fixed in 2.17.0.
- No fix released. The advisory names 2.17.0 as the fix, which the registry doesn't have yet. The latest release, 2.16.0, is still affected.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/maven/com.shopizer:shopizer
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
