# com.rapid7:jenkinsci-appspider-plugin (Maven) vulnerabilities

5 known vulnerabilities (1 high, 3 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://central.sonatype.com/artifact/com.rapid7/jenkinsci-appspider-plugin

## Advisories (5)

### [CVE-2026-48923](https://cve.now/CVE-2026-48923): Jenkins AppSpider Plugin 1.0.17 and earlier does not perform a permission check in a method implementing form validation, allowing…

- Severity: Medium 4.3
- Published: May 27, 2026
- Affected: fixed in 1.0.18.

### [CVE-2024-28155](https://cve.now/CVE-2024-28155): Jenkins AppSpider Plugin 1.0.16 and earlier does not perform permission checks in several HTTP endpoints, allowing attackers with…

- Severity: Medium 4.3
- Published: Mar 6, 2024
- Affected: fixed in 1.0.17.

### [CVE-2023-32999](https://cve.now/CVE-2023-32999): A missing permission check in Jenkins AppSpider Plugin 1.0.15 and earlier allows attackers with Overall/Read permission to connect to an…

- Severity: Medium 4.3
- Published: May 16, 2023
- Affected: fixed in 1.0.16.

### [CVE-2023-32998](https://cve.now/CVE-2023-32998): A cross-site request forgery (CSRF) vulnerability in Jenkins AppSpider Plugin 1.0.15 and earlier allows attackers to connect to an…

- Severity: High 8.8
- Published: May 16, 2023
- Affected: fixed in 1.0.16.

### [CVE-2020-2314](https://cve.now/CVE-2020-2314): Jenkins AppSpider Plugin 1.0.12 and earlier stores a password unencrypted in its global configuration file on the Jenkins controller where…

- Severity: Unrated
- Published: Nov 4, 2020
- Affected: fixed in 1.0.13.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/maven/com.rapid7:jenkinsci-appspider-plugin
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
