# helm.sh/helm (Go) vulnerabilities

9 known vulnerabilities (2 medium, 4 low), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://pkg.go.dev/helm.sh/helm

## Advisories (9)

### [CVE-2025-55198](https://cve.now/CVE-2025-55198): Helm May Panic Due To Incorrect YAML Content

- Severity: Medium 6.5
- Published: Aug 13, 2025
- Affected: all versions.

### [CVE-2025-55199](https://cve.now/CVE-2025-55199): Helm Charts with Specific JSON Schema Values Can Cause Memory Exhaustion

- Severity: Medium 6.5
- Published: Aug 13, 2025
- Affected: all versions.

### [CVE-2020-15187](https://cve.now/CVE-2020-15187): Duplicate plugin entries in Helm

- Severity: Low 3.0
- Published: Sep 17, 2020
- Affected: from 2.0.0, fixed in 2.16.11.

### [CVE-2020-15186](https://cve.now/CVE-2020-15186): Improper sanitization of plugin names in Helm

- Severity: Low 3.4
- Published: Sep 17, 2020
- Affected: fixed in 2.16.11.

### [CVE-2020-15185](https://cve.now/CVE-2020-15185): Duplicated chart entries in Helm

- Severity: Low 2.2
- Published: Sep 17, 2020
- Affected: fixed in 2.16.11.

### [CVE-2020-15184](https://cve.now/CVE-2020-15184): Aliases are never checked in Helm

- Severity: Low 3.7
- Published: Sep 17, 2020
- Affected: fixed in 2.16.11.

### [CVE-2019-18658](https://cve.now/CVE-2019-18658): In Helm 2.x before 2.15.2, commands that deal with loading a chart as a directory or packaging a chart provide an opportunity for a…

- Severity: Unrated
- Published: Nov 12, 2019
- Affected: from 2.0.0+incompatible, fixed in 2.15.2+incompatible; from 2.0.0, fixed in 2.15.2.

### [CVE-2019-1010275](https://cve.now/CVE-2019-1010275): helm Before 2.7.2 is affected by: CWE-295: Improper Certificate Validation.

- Severity: Unrated
- Published: Jul 17, 2019
- Affected: fixed in 2.7.2; fixed in 2.7.2+incompatible.

### [CVE-2019-1000008](https://cve.now/CVE-2019-1000008): All versions of Helm between Helm \>=2.0.0 and \< 2.12.2 contains a CWE-22: Improper Limitation of a Pathname to a Restricted Directory…

- Severity: Unrated
- Published: Feb 4, 2019
- Affected: from 2.0.0+incompatible, fixed in 2.12.2+incompatible; from 2.0.0, fixed in 2.12.2.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/go/helm.sh/helm
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
