# github.com/osrg/gobgp (Go) vulnerabilities

6 known vulnerabilities (2 high, 4 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: v2.0.0+incompatible (Dec 30, 2018): affected by 6 advisories
- Newest unaffected release: Every release is affected by at least one advisory
- Releases: 1 since v2.0.0+incompatible (Dec 30, 2018)
- Registry: https://pkg.go.dev/github.com/osrg/gobgp
- Releases read: Nov 8, 2026

## Version timeline

Affected versions per advisory, in version order:

- CVE-2026-7737: v2.0.0+incompatible (through the newest release)
- CVE-2026-30405: v2.0.0+incompatible (through the newest release)
- CVE-2025-43973: v2.0.0+incompatible (through the newest release)
- CVE-2025-43972: v2.0.0+incompatible (through the newest release)
- CVE-2025-43971: v2.0.0+incompatible (through the newest release)
- CVE-2025-43970: v2.0.0+incompatible (through the newest release)

## Advisories (6)

### [CVE-2026-7737](https://cve.now/CVE-2026-7737): osrg GoBGP BMP Parser bmp.go BMPStatisticsReport.ParseBody out-of-bounds

- Severity: Medium 6.9
- Published: May 4, 2026
- Affected: fixed in 4.4.0.
- No fix released. The advisory names 4.4.0 as the fix, which the registry doesn't have yet. The latest release, v2.0.0+incompatible, is still affected.

### [CVE-2026-30405](https://cve.now/CVE-2026-30405): An issue in GoBGP gobgpd v.4.2.0 allows a remote attacker to cause a denial of service via the NEXT\_HOP path attribute

- Severity: High 7.5
- Published: Mar 16, 2026
- Affected: all versions.
- No fix released. The latest release, v2.0.0+incompatible, is still affected.

### [CVE-2025-43973](https://cve.now/CVE-2025-43973): An issue was discovered in GoBGP before 3.35.0.

- Severity: Medium 6.8
- Published: Apr 21, 2025
- Affected: all versions.
- No fix released. The latest release, v2.0.0+incompatible, is still affected.

### [CVE-2025-43972](https://cve.now/CVE-2025-43972): An issue was discovered in GoBGP before 3.35.0.

- Severity: Medium 6.8
- Published: Apr 21, 2025
- Affected: all versions.
- No fix released. The latest release, v2.0.0+incompatible, is still affected.

### [CVE-2025-43971](https://cve.now/CVE-2025-43971): An issue was discovered in GoBGP before 3.35.0.

- Severity: High 8.6
- Published: Apr 21, 2025
- Affected: all versions.
- No fix released. The latest release, v2.0.0+incompatible, is still affected.

### [CVE-2025-43970](https://cve.now/CVE-2025-43970): An issue was discovered in GoBGP before 3.35.0.

- Severity: Medium 4.3
- Published: Apr 21, 2025
- Affected: all versions.
- No fix released. The latest release, v2.0.0+incompatible, is still affected.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/go/github.com/osrg/gobgp
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
