# github.com/hyperledger/fabric (Go) vulnerabilities

6 known vulnerabilities (3 high, 1 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://pkg.go.dev/github.com/hyperledger/fabric

## Advisories (6)

### [CVE-2024-45244](https://cve.now/CVE-2024-45244): Hyperledger Fabric through 3.0.0 and 2.5.x through 2.5.9 do not verify that a request has a timestamp within the expected time window.

- Severity: Medium 5.3
- Published: Aug 25, 2024
- Affected: all versions; through 2.5.9.

### [CVE-2023-46132](https://cve.now/CVE-2023-46132): Crosslinking transaction attack in hyperledger/fabric

- Severity: High 7.1
- Published: Nov 14, 2023
- Affected: from 1.0.0-alpha, fixed in 2.2.14; from 2.3.0, fixed in 2.5.5.

### [CVE-2022-36023](https://cve.now/CVE-2022-36023): Remote denial of service in Hyperledger Fabric Gateway

- Severity: High 7.0
- Published: Aug 18, 2022
- Affected: from 2.4.0, fixed in 2.4.6.

### [CVE-2022-31121](https://cve.now/CVE-2022-31121): Improper Input Validation in fabric hyperledger

- Severity: High 7.5
- Published: Jul 7, 2022
- Affected: fixed in 2.2.7; from 2.3.0, fixed in 2.4.5.

### [CVE-2021-43669](https://cve.now/CVE-2021-43669): A vulnerability has been detected in HyperLedger Fabric v1.4.0, v2.0.0, v2.0.1, v2.3.0.

- Severity: Unrated
- Published: Nov 18, 2021
- Affected: fixed in 2.4.0.

### [CVE-2021-43667](https://cve.now/CVE-2021-43667): A vulnerability has been detected in HyperLedger Fabric v1.4.0, v2.0.0, v2.1.0.

- Severity: Unrated
- Published: Nov 18, 2021
- Affected: from 2.3.0, fixed in 2.3.3; fixed in 2.2.4.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/go/github.com/hyperledger/fabric
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
