- Latest release
- Not known: cve.now hasn't read this package's releases
- Newest unaffected release
- Not known without release data
- Advisories
- 6 · 3 high, 1 medium
- Registry
- pkg.go.dev
Advisories 6
- CVE-2024-45244Medium 5.3
Hyperledger Fabric through 3.0.0 and 2.5.x through 2.5.9 do not verify that a request has a timestamp within the expected time window.
Affected: all versions; through 2.5.9.
- CVE-2023-46132High 7.1
Crosslinking transaction attack in hyperledger/fabric
Affected: from 1.0.0-alpha, fixed in 2.2.14; from 2.3.0, fixed in 2.5.5.
- CVE-2022-36023High 7.0
Remote denial of service in Hyperledger Fabric Gateway
Affected: from 2.4.0, fixed in 2.4.6.
- CVE-2022-31121High 7.5
Improper Input Validation in fabric hyperledger
Affected: fixed in 2.2.7; from 2.3.0, fixed in 2.4.5.
- CVE-2021-43669Unrated
A vulnerability has been detected in HyperLedger Fabric v1.4.0, v2.0.0, v2.0.1, v2.3.0.
Affected: fixed in 2.4.0.
- CVE-2021-43667Unrated
A vulnerability has been detected in HyperLedger Fabric v1.4.0, v2.0.0, v2.1.0.
Affected: from 2.3.0, fixed in 2.3.3; fixed in 2.2.4.