- Latest release
- v1.16.0 (Nov 5, 2026): no advisory affects it
- Newest unaffected release
- v1.16.0 (Nov 5, 2026), the latest release
- Advisories
- 6 · 5 critical, 1 high
- Releases
- 19 since v0.32.0 (Apr 8, 2026)
- Registry
- pkg.go.dev
- Releases read
- Nov 8, 2026
Version timeline
- CVE-2026-11720Affects v0.32.0 to v1.2.0 (v1.3.0 is outside it)
- CVE-2026-11719Affects v0.32.0 to v1.3.0 (v1.4.0 is outside it)
- CVE-2026-11718Affects v0.32.0 to v1.3.0 (v1.4.0 is outside it)
- CVE-2026-11717Affects v0.32.0 to v1.3.0 (v1.4.0 is outside it)
- CVE-2026-11624No published release is affectedNo published release is affected
- CVE-2026-9739Affects v0.32.0 to v1.1.0 (v1.2.0 is outside it)
Advisories 6
- CVE-2026-11720Critical 9.3
Path Traversal in googleapis/mcp-toolbox HTTP Tool URL Builder
Affected: fixed in 1.3.0.
Fixed in v1.3.0 (released May 21, 2026, 39 days before disclosure).
The latest release, v1.16.0, is not affected.
- CVE-2026-11719High 8.6
An authenticated authorization bypass vulnerability exists in MCP Toolbox for Databases due to missing scope enforcement across older…
Affected: fixed in 1.4.0.
Fixed in v1.4.0 (released Jun 4, 2026, 14 days before disclosure).
The latest release, v1.16.0, is not affected.
- CVE-2026-11718Critical 9.3
An authentication bypass vulnerability exists in the generic opaque token validation path (validateOpaqueToken) of googleapis/mcp-toolbox.
Affected: fixed in 1.4.0.
Fixed in v1.4.0 (released Jun 4, 2026, 14 days before disclosure).
The latest release, v1.16.0, is not affected.
- CVE-2026-11717Critical 9.3
An authentication bypass vulnerability exists in the generic opaque token validation path (validateOpaqueToken) of googleapis/mcp-toolbox.
Affected: fixed in 1.4.0.
Fixed in v1.4.0 (released Jun 4, 2026, 14 days before disclosure).
The latest release, v1.16.0, is not affected.
- CVE-2026-11624Critical 9.4
The Model Context Protocol has a security warning advising servers to validate the "Origin" header on all incoming connections to prevent…
Affected: fixed in 0.25.0.
Fixed in v0.32.0 (released Apr 8, 2026, 66 days before disclosure, the advisory names 0.25.0, which was never published).
The latest release, v1.16.0, is not affected.
- CVE-2026-9739Critical 9.4
Vulnerable to DNS rebinding attacks when using SSE (http://b/499408790).
Affected: fixed in 1.2.0.
Fixed in v1.2.0 (released May 7, 2026, 20 days before disclosure).
The latest release, v1.16.0, is not affected.