Skip to main content
← Go

github.com/containers/podman/v2

17 known vulnerabilities (1 critical, 5 high, 7 medium), with the versions each affects and the releases that fix them.

Latest release
v2.2.1 (Dec 7, 2020): affected by 15 advisories
Newest unaffected release
Every release is affected by at least one advisory
Advisories
17 · 1 critical, 5 high, 7 medium
Releases
8 since v2.1.0 (Sep 22, 2020)
Registry
pkg.go.dev
Releases read
Nov 8, 2026

Version timeline

  • CVE-2026-94603
    Affects v2.1.0-rc1 to v2.2.1 (through the newest release)
  • CVE-2026-19730
    Affects v2.1.0-rc1 to v2.2.1 (through the newest release)
  • CVE-2026-55686
    Affects v2.1.0-rc1 to v2.2.1 (through the newest release)
  • CVE-2026-57231
    Affects v2.1.0-rc1 to v2.2.1 (through the newest release)
  • CVE-2026-33414
    Affects v2.1.0-rc1 to v2.2.1 (through the newest release)
  • CVE-2025-4953
    Affects v2.1.0-rc1 to v2.2.1 (through the newest release)
  • CVE-2025-9566
    Affects v2.1.0-rc1 to v2.2.1 (through the newest release)
  • CVE-2025-6032
    Affects v2.1.0-rc1 to v2.2.1 (through the newest release)
  • CVE-2024-9407
    Affects v2.1.0-rc1 to v2.2.1 (through the newest release)
  • CVE-2024-3056
    Affects v2.1.0-rc1 to v2.2.1 (through the newest release)
  • CVE-2022-4122
    Affects v2.1.0-rc1 to v2.2.1 (through the newest release)
  • CVE-2022-27649
    Affects v2.1.0-rc1 to v2.2.1 (through the newest release)
Show all 17 advisoriesShow fewer advisories
  • CVE-2021-4024
    Affects v2.1.0-rc1 to v2.2.1 (through the newest release)
  • CVE-2020-14370
    No published release is affected
    No published release is affected
  • CVE-2020-1726
    No published release is affected
    No published release is affected
  • CVE-2019-18466
    Affects v2.1.0-rc1 to v2.2.1 (through the newest release)
  • CVE-2018-10856
    Affects v2.1.0-rc1 to v2.2.1 (through the newest release)
Every release cve.now has on record, lowest version on the left; each bar is a run of versions an advisory affects.

Advisories 17

  • CVE-2026-94603Critical 10.0

    Podman: The `podman run` command can be instructed to disable almost all sandboxing by image annotation

    Affected: all versions.

    No fix released. The latest release, v2.2.1, is still affected.

  • CVE-2026-19730Medium 4.2

    Podman: podman: quadlet install --replace non-truncating write retains removed host-access directives

    Affected: all versions.

    No fix released. The latest release, v2.2.1, is still affected.

  • CVE-2026-55686Medium 5.3

    Podman: WORKDIR symlink traversal vulnerability

    Affected: all versions.

    No fix released. The latest release, v2.2.1, is still affected.

  • Podman: Malformed Image can trick podman run into leaking host environment variables into the container

    Affected: through 2.2.1; all versions.

    No fix released. The latest release, v2.2.1, is still affected.

  • CVE-2026-33414Medium 4.0

    PowerShell Command Injection in Podman HyperV Machine

    Affected: all versions.

    No fix released. The latest release, v2.2.1, is still affected.

  • Podman: build context bind mount

    Affected: all versions.

    No fix released. The latest release, v2.2.1, is still affected.

  • Podman: podman kube play command may overwrite host files

    Affected: all versions.

    No fix released. The latest release, v2.2.1, is still affected.

  • Podman: podman missing tls verification

    Affected: all versions.

    No fix released. The latest release, v2.2.1, is still affected.

  • CVE-2024-9407Medium 4.7

    Buildah: podman: improper input validation in bind-propagation option of dockerfile run --mount instruction

    Affected: fixed in 5.2.4; all versions.

    No fix released. The latest release, v2.2.1, is still affected.

  • Podman: kernel: containers in shared ipc namespace are vulnerable to denial of service attack

    Affected: through 5.2.0; all versions.

    No fix released. The latest release, v2.2.1, is still affected.

  • CVE-2022-4122Medium 5.3

    A vulnerability was found in buildah.

    Affected: all versions.

    No fix released. The latest release, v2.2.1, is still affected.

  • A flaw was found in Podman, where containers were started incorrectly with non-empty default permissions.

    Affected: all versions.

    No fix released. The latest release, v2.2.1, is still affected.

  • A flaw was found in podman.

    Affected: all versions.

    No fix released. The latest release, v2.2.1, is still affected.

  • An information disclosure vulnerability was found in containers/podman in versions before 2.0.5.

    Affected: fixed in 2.0.5.

    Fixed in v2.1.0 (released Sep 22, 2020, 1 day before disclosure, the advisory names 2.0.5, which was never published).

    The latest release, v2.2.1, is not affected.

  • CVE-2020-1726Medium 5.9

    A flaw was discovered in Podman where it incorrectly allows containers when created to overwrite existing files in volumes, even if they…

    Affected: fixed in 2.0.6.

    Fixed in v2.1.0 (released Sep 22, 2020, 224 days after disclosure, the advisory names 2.0.6, which was never published).

    The latest release, v2.2.1, is not affected.

Show all 17 advisoriesShow fewer advisories
  • An issue was discovered in Podman in libpod before 1.6.0.

    Affected: all versions.

    No fix released. The latest release, v2.2.1, is still affected.

  • CVE-2018-10856Medium 5.3

    It has been discovered that podman before version 0.6.1 does not drop capabilities when executing a container as a non-root user.

    Affected: all versions.

    No fix released. The latest release, v2.2.1, is still affected.