Skip to main content
← Vulnerabilities

Dell Alienware Command Center (AWCC), version(s) Versions up to and including 6.14.20.0, contain(s) an Improper Authorization in Handler…

Affects Dell Alienware Command Center (AWCC) versions up to and including 6.14.20.0. Fixed in 6.14.54.0.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

5.8MediumCNA
Exploited
No known exploitation
Fix
Fixed in 6.14.54.0
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Dell Alienware Command Center (AWCC) version up to and including 6.14.20.0

Published
Last modified
Published
Not listed in CISA KEV
19/100 · provisional
Specific setups only
Fix
Fixed in 6.14.54.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Dell Alienware Command Center, a utility for managing Alienware gaming hardware, is affected by this vulnerability. A remote, unauthenticated attacker could potentially exploit it to execute commands, carry out phishing attacks, or run code remotely on the affected system.

Read the original description

Dell Alienware Command Center (AWCC), version(s) Versions up to and including 6.14.20.0, contain(s) an Improper Authorization in Handler for Custom URL Scheme vulnerability. An unauthenticated attacker with remote access could potentially exploit this vulnerability, leading to Command execution, Launch of phishing attacks, and Remote execution.

What to do

  • Check whether your setup matches what the bug needs.

    Dell Alienware Command Center (AWCC) version up to and including 6.14.20.0
  • Upgrade to a fixed version: 6.14.54.0.

Timeline

  1. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  2. CVE published
  3. First seen by cve.now1 day
  4. Record last updated

Affected versions

  • Dell Alienware Command Center (AWCC)

    fixed in 6.14.54.0

Evidence 1

  1. Advisory

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-91900

What does this mean?

An improper authorization flaw in a handler of Dell Alienware Command Center lets actions run that should be restricted. The advisory lists command execution, launching phishing attacks, and remote execution as possible impacts.Source: dell.com

Am I affected, and how do I check?

Versions up to and including 6.14.20.0 are affected. Compare the installed AWCC version number against that range to check a system.Source: dell.com

What should I do about it?

Update Dell Alienware Command Center to version 6.14.54.0 or later, the fixed version listed in the advisory.Source: dell.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data