Skip to main content
← Vulnerabilities

Dell Alienware Command Center (AWCC), versions prior to 6.14.54.0, contain an Improper Verification of Cryptographic Signature…

Affects Dell Alienware Command Center (AWCC) versions before 6.14.54.0. Fixed in 6.14.54.0. Vendor rating not given; CVSS score is 8.1 (high).

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.1HighCNA
Exploited
No known exploitation
Fix
Fixed in 6.14.54.0
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 6.14.54.0.

Published
Last modified
Published
Not listed in CISA KEV
16/100 · provisional
Unclear
Fix
Fixed in 6.14.54.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Dell Alienware Command Center (AWCC), versions prior to 6.14.54.0, contain an Improper Verification of Cryptographic Signature vulnerability. An unauthenticated attacker with adjacent network access could potentially exploit this vulnerability, leading to Arbitrary Code Execution and Elevation of Privilege.

What to do

  • Upgrade to a fixed version: 6.14.54.0.

Timeline

  1. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  2. CVE published
  3. First seen by cve.now1 day
  4. Record last updated

Affected versions

  • Dell Alienware Command Center (AWCC)

    fixed in 6.14.54.0

Evidence 1

  1. Advisory

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-91898

What does this mean?

AWCC fails to properly verify a cryptographic signature, which can allow arbitrary code to run and let an attacker gain elevated privileges. The facts do not describe how the signature check is bypassed.Source: dell.com

Am I affected, and how do I check?

All AWCC versions before 6.14.54.0 are affected. To check your version, look at the installed version shown in the AWCC application or its program details in Windows.Source: dell.com

What should I do about it?

Upgrade Alienware Command Center to version 6.14.54.0 or later.Source: dell.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data