Rancher meta proxy allowlist bypass leading to server-side request forgery
Affects Rancher 2.11.0 to before 2.15.3 where traffic reaches the server without an HTTP-aware ingress, such as via layer 4 load balancers or TLS passthrough. Fixed in each branch's patch release, with 2.15.3 for the 2.15 line.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 2.15.3, 2.14.7, 2.13.11, 2.12.15, 2.11.19
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Rancher versions in the affected ranges (2.15.0 to before 2.15.3, 2.14.0 to before 2.14.7, 2.13.0 to before 2.13.11, 2.12.0 to before 2.12.15, 2.11.0 to before 2.11.19) The attacker's request reaches the Rancher server as an HTTP/1.1 request carrying the full destination URL in the request line, with no HTTP-aware proxy rewriting it Traffic reaches Rancher over a direct path such as a layer 4 load balancer, TLS passthrough, direct Service access, hostPort or hostNetwork, rather than an HTTP-aware ingress controller
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 26/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 2.15.3, 2.14.7, 2.13.11, 2.12.15, 2.11.19
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
SUSE Rancher Manager, the Kubernetes management platform, is affected through its meta proxy endpoint, where a flaw lets requests reach destinations that are supposed to be blocked by its allowlist. An attacker who can reach this endpoint could use the server to make requests to internal or otherwise restricted systems (server-side request forgery).
Read the original description
A security vulnerability exists in the SUSE Rancher Manager meta proxy endpoint (/meta/proxy). This endpoint is intended to forward requests only to destinations that appear on a configured allowlist. The allowlist decision was evaluated in a place where it could not stop a request from being forwarded, so a rejected destination was logged but the request was still handed to the proxy's transport. This affects SUSE Rancher 2.15.0 up to 2.15.3, 2.14.0 up to 2.14.7, 2.13.0 up to 2.13.11, 2.12.0 up to 2.12.15, 2.11.0 up to 2.11.19 and potentially older EOL versions.
What to do
Check whether your setup matches what the bug needs.
Rancher versions in the affected ranges (2.15.0 to before 2.15.3, 2.14.0 to before 2.14.7, 2.13.0 to before 2.13.11, 2.12.0 to before 2.12.15, 2.11.0 to before 2.11.19) The attacker's request reaches the Rancher server as an HTTP/1.1 request carrying the full destination URL in the request line, with no HTTP-aware proxy rewriting it Traffic reaches Rancher over a direct path such as a layer 4 load balancer, TLS passthrough, direct Service access, hostPort or hostNetwork, rather than an HTTP-aware ingress controllerUpgrade to a fixed version: 2.15.3, 2.14.7, 2.13.11, 2.12.15, 2.11.19.
Workaround: Route all traffic through an HTTP-aware reverse proxy, restrict pod access to the Rancher Service with NetworkPolicy, and restrict the Rancher server's egress; these reduce exposure but do not fully fix the issue
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- Rancher
From 2.15.0 · fixed in 2.15.3; From 2.14.0 · fixed in 2.14.7; From 2.13.0 · fixed in 2.13.11; From 2.12.0 · fixed in 2.12.15; From 2.11.0 · fixed in 2.11.19
Evidence 1
- Advisory
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-88809
What does this mean?
An authenticated user can make the Rancher server send requests to internal hosts that its allowlist should block. This can disclose data from internal systems and reach internal systems from the server's network position, possibly including cloud instance metadata credentials.Source: github.com
Am I affected, and how do I check?
Affected versions are Rancher 2.15.0 to before 2.15.3, 2.14.0 to before 2.14.7, 2.13.0 to before 2.13.11, 2.12.0 to before 2.12.15, and 2.11.0 to before 2.11.19. The issue requires an HTTP/1.1 request to reach the Rancher server with no HTTP-aware proxy rewriting it, which happens with direct paths such as layer 4 load balancers, TLS passthrough, direct Service access, hostPort, or hostNetwork. Check the installed Rancher server version and how traffic is routed to it.Source: github.com
What should I do about it?
Upgrade to the fixed release for your branch: 2.15.3, 2.14.7, 2.13.11, 2.12.15, or 2.11.19. The fix is only in these patched releases, and the workaround does not fully fix the issue.Source: github.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data