Skip to main content
← Vulnerabilities

Control Web Panel (CWP) < 1.30 Unauthenticated Loopback API Root Access

Control Web Panel (CWP) before 1.30 is affected where the loopback API service can be reached. The fix is in 1.30.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.6HighCNA
Exploited
No known exploitation
Fix
Fixed in 1.30
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Control Web Panel (CWP) before version 1.30 Attacker must be able to reach the loopback API service

Published
Last modified
Published
Not listed in CISA KEV
15/100 · provisional
Specific setups only
Fix
Fixed in 1.30
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Control Web Panel (CWP), a web hosting control panel, is affected by this vulnerability. An attacker who can reach its local API service can perform privileged administrative actions as root without authenticating.

Read the original description

Control Web Panel (CWP) before webpanel_version 1.30 contains a missing authentication vulnerability that allows attackers able to reach the loopback API service to invoke root-privileged API routes without presenting an access token. Attackers can access endpoints such as /v1/restoredatabase/, /generaluser/, /last_access/, /valid_user/, /valid_token/, and /user_panel_dashboard/ to perform unauthorized actions with root privileges.

What to do

  • Check whether your setup matches what the bug needs.

    Control Web Panel (CWP) before version 1.30 Attacker must be able to reach the loopback API service
  • Upgrade to a fixed version: 1.30.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  4. Record last updated

Affected versions

  • Control Web Panel Control Web Panel

    fixed in 1.30

Evidence 3

  1. Patch
  2. Exploit
  3. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-77877

What does this mean?

The panel has a missing authentication flaw in its loopback API. An unauthenticated attacker who can reach that API can invoke root-privileged routes and perform unauthorized actions with root privileges.Source: vulncheck.com, control-webpanel.com

Am I affected, and how do I check?

Control Web Panel versions before webpanel_version 1.30 are affected, and the issue requires that the loopback API service be reachable. The installed webpanel_version can be compared against 1.30 to determine whether a system falls in the affected range.Source: vulncheck.com, control-webpanel.com

What should I do about it?

Upgrade Control Web Panel to version 1.30 or later, which is the fixed release. No workaround is listed in the facts.Source: vulncheck.com, control-webpanel.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data