Skip to main content
← Vulnerabilities

Control Web Panel (CWP) < 1.16 File Write and Command Injection via phpini_editor

Affects Control Web Panel versions before 1.16 where users have access to the phpini_editor user panel module. Fixed in 1.16.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.7HighCNA
Exploited
No known exploitation
Fix
Fixed in 1.16
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Control Web Panel (CWP) version before 1.16 (webpanel_version) Attacker has access to the phpini_editor user panel module

Published
Last modified
Published
Not listed in CISA KEV
18/100 · provisional
Specific setups only
Fix
Fixed in 1.16
None on Exploit-DB, Metasploit or GitHub
On X
View the cve.now post
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Control Web Panel (CWP), a web hosting control panel, is affected through its PHP ini editor module in the user panel. An attacker with access to this module could write arbitrary files on the server and run operating system commands, potentially gaining full remote control of the host.

Read the original description

Control Web Panel (CWP) before webpanel_version 1.16 contains an arbitrary file write and OS command injection vulnerability in the phpini_editor user panel module that allows attackers with access to the module to write attacker-controlled content to arbitrary paths and execute arbitrary OS commands. Attackers can exploit the acc=update action to write files via file_put_contents without path confinement and the acc=addlabelphpiniadv action to pass unsanitized input into shell_exec, achieving code execution in the user panel context.

What to do

  • Check whether your setup matches what the bug needs.

    Control Web Panel (CWP) version before 1.16 (webpanel_version) Attacker has access to the phpini_editor user panel module
  • Upgrade to a fixed version: 1.16.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Posted on X by cve.now
  4. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  5. Record last updated

Affected versions

  • Control Web Panel Control Web Panel

    fixed in 1.16

Evidence 3

  1. Patch
  2. Link
  3. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-73697

What does this mean?

The phpini_editor module lets an attacker write files to paths they choose and run arbitrary operating system commands. Together these can lead to remote code execution.Source: vulncheck.com

Am I affected, and how do I check?

Control Web Panel (CWP) versions before 1.16 are affected, provided the attacker has access to the phpini_editor user panel module. To check a installation, look at the webpanel_version value.Source: vulncheck.com

What should I do about it?

Upgrade Control Web Panel to version 1.16 or later, which contains the fix.Source: vulncheck.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data