Skip to main content
← Vulnerabilities

Control Web Panel (CWP) < 1.16 Path Traversal via services/users/index.php

Control Web Panel versions before 1.16 are affected via the services/users/index.php path traversal. No vendor rating is given. Fixed in 1.16.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.7HighCNA
Exploited
No known exploitation
Fix
Fixed in 1.16
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Control Web Panel (CWP) versions before 1.16 (webpanel_version)

Published
Last modified
Published
Not listed in CISA KEV
17/100 · provisional
Specific setups only
Fix
Fixed in 1.16
None on Exploit-DB, Metasploit or GitHub
On X
View the cve.now post

Summary

Control Web Panel (CWP), a web hosting control panel, is affected by a path traversal flaw that allows attackers to include arbitrary local PHP files on the server. The impact is local PHP file inclusion, which could let an attacker read sensitive files or execute code available on the affected system.

Read the original description

Control Web Panel (CWP) before webpanel_version 1.16 contains a path traversal vulnerability in services/users/index.php that allows attackers to include arbitrary local PHP files by supplying an unsanitized module name parameter concatenated directly into an include path. Attackers can inject directory traversal sequences into the module name to achieve local file inclusion and execute arbitrary PHP code in the user panel context.

What to do

  • Check whether your setup matches what the bug needs.

    Control Web Panel (CWP) versions before 1.16 (webpanel_version)
  • Upgrade to a fixed version: 1.16.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Record last updated
  4. Posted on X by cve.now

Affected versions

  • Control Web Panel Control Web Panel

    fixed in 1.16

Evidence 3

  1. Patch
  2. Link
  3. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-73695

What does this mean?

Attackers can inject directory traversal sequences into the module name to include arbitrary local PHP files. This lets them execute arbitrary PHP code in the user panel context.Source: vulncheck.com, vulncheck.com

Am I affected, and how do I check?

Control Web Panel (CWP) versions before 1.16 are in the affected range. The version is listed in the webpanel_version value, so compare that value against 1.16.Source: vulncheck.com, vulncheck.com

What should I do about it?

Upgrade Control Web Panel to version 1.16 or later, which is the listed fixed version. No workaround is listed in the facts.Source: vulncheck.com, vulncheck.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data