Skip to main content
← Vulnerabilities

CVE-2026-120627

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

—Not rated
Exploited
No known exploitation
Fix
No fix listed
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Affected PIA Firefox extension version 4.0.5 VPN proxy turned on in the extension

Published
Last modified
Published
Not listed in CISA KEV
17/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub

Summary

The Private Internet Access browser extension for Firefox is affected. A malicious website can trigger a Basic authentication prompt that causes the extension to leak the user's PIA proxy credentials.

Read the original description

The Private Internet Access Extension for Firefox contains an unguarded onAuthRequired authentication handler, leading to leakage of PIA proxy credentials when a user visits any malicious website that issues a Basic auth challenge. This issue was fixed in version 3.2.5, but reintroduced in later versions.

What to do

  • Check whether your setup matches what the bug needs.

    Affected PIA Firefox extension version 4.0.5 VPN proxy turned on in the extension
  • Workaround: The checked facts do not include a vendor fix or workaround. Turning off the VPN proxy in the extension is the only limiting step the facts describe, and it stops the affected setup until a fix is available.

Timeline

  1. CVE published
  2. Record last updated
  3. First seen by cve.now

Affected versions

  • Private Internet Access Firefox extension

    From 3.2.5 · through 4.0.5

Evidence 2

  1. Repository
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-120627

What does this mean?

The Private Internet Access Firefox extension leaks its stored authentication secrets, including the proxy credentials and bearer token. Those secrets can let a third party reach the account and track activity across VPN exit nodes.Source: github.com

Am I affected, and how do I check?

The advisory names PIA Firefox extension version 4.0.5 (released December 23, 2024) as affected, and the bug needs the VPN proxy turned on in the extension. To check, open the extension's version in Firefox's add-ons manager and see whether the VPN proxy is enabled in its settings.Source: github.com

What should I do about it?

No fixed version is listed in the checked facts, so no upgrade target can be confirmed. Check the vendor's advisory for a fixed release before relying on any update.Source: github.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What if there's no patch?

The checked facts do not include a vendor fix or workaround. Turning off the VPN proxy in the extension is the only limiting step the facts describe, and it stops the affected setup until a fix is available.Source: github.com