An Otter Wiki before 2.26.2 Stored XSS via Math Code Block
Otter Wiki versions 2.0.0 up to 2.26.2 are affected, where users who can edit pages can inject script through a math code block. CVSS scores it 5.3 (medium). Fixed in 2.26.2.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 2.26.2
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Affects otterwiki versions 2.0.0 up to but not including 2.26.2 Attacker must be able to edit wiki pages
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 17/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 2.26.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
An Otter Wiki, a lightweight wiki application, is affected by a stored cross-site scripting flaw in its page rendering of math code blocks. Attackers who can edit pages (including anonymous users under the default setup) can embed malicious scripts that run in the browser of every person who views the affected page.
Read the original description
An Otter Wiki before 2.26.2 contains a stored cross-site scripting vulnerability in OtterwikiMdRenderer.block_code that allows attackers who can edit pages, including anonymous users under the default configuration, to inject arbitrary script. Attackers can place HTML inside a math fenced code block, which is rendered unescaped and executes for every viewer of the page.
What to do
Check whether your setup matches what the bug needs.
Affects otterwiki versions 2.0.0 up to but not including 2.26.2 Attacker must be able to edit wiki pagesUpgrade to a fixed version: 2.26.2.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- redimp otterwiki
From 2.0.0 · fixed in 2.26.2
Evidence 3
- Patch
- Repository
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-120500
What does this mean?
The bug is a stored cross-site scripting flaw in the math code block. A user who can edit wiki pages can inject arbitrary script, which then runs for every viewer of that page.Source: vulncheck.com
Am I affected, and how do I check?
Otter Wiki versions from 2.0.0 up to but not including 2.26.2 are affected. The attacker must be able to edit wiki pages, so check the installed Otter Wiki version against this range.Source: vulncheck.com
What should I do about it?
Upgrade Otter Wiki to version 2.26.2 or later, which contains the fix.Source: vulncheck.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data