Skip to main content
← Vulnerabilities

LaraDashboard before 1.4.9 Stored XSS via LaraBuilder design_json Block Content

LaraDashboard versions before 1.4.9, including v1.4.2, are affected when LaraBuilder text-editor or html blocks render unsanitized content. Fixed in 1.4.9.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

5.1MediumCNA
Exploited
No known exploitation
Fix
Fixed in 1.4.9
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. LaraDashboard version v1.4.2 is affected Attacker has post.create permission to store builder blocks Payload is in a LaraBuilder text-editor or html block rendered without sanitization

Published
Last modified
Published
Not listed in CISA KEV
13/100 · provisional
Specific setups only
Fix
Fixed in 1.4.9
None on Exploit-DB, Metasploit or GitHub

Summary

LaraDashboard before 1.4.9 contains a stored cross-site scripting vulnerability that allows authenticated users with post.create or post.edit permission to inject scripts via unsanitized LaraBuilder design_json block content. Attackers can save text-editor, HTML, text or heading blocks containing script or event-handler markup that executes in administrator or Superadmin sessions viewing the builder, preview or page.

What to do

  • Check whether your setup matches what the bug needs.

    LaraDashboard version v1.4.2 is affected Attacker has post.create permission to store builder blocks Payload is in a LaraBuilder text-editor or html block rendered without sanitization
  • Upgrade to a fixed version: 1.4.9.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • LaraDashboard LaraDashboard

    fixed in 1.4.9

Evidence 7

  1. Advisory
  2. Advisory
  3. Advisory
  4. Patch
  5. Repository
Show all 7 sourcesShow fewer sources
  1. Repository
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-120488

What does this mean?

LaraBuilder text-editor and html blocks render stored HTML and JavaScript without sanitization, so a script planted in a block runs when an administrator or editor opens the builder preview or page. The script then acts with that user's privileges.Source: github.com

Am I affected, and how do I check?

The affected range runs from the start up to but not including 1.4.9, and the advisory lists v1.4.2 as affected. The setup involves LaraBuilder text-editor or html blocks and users with post.create, which includes authors, editors, and members allowed by the membership module. To check the version, look at the LaraDashboard version in the installation.Source: github.com

What should I do about it?

Upgrade LaraDashboard to version 1.4.9 or later.Source: github.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data