Skip to main content
Early warnings
SZB-fe042b91fc

ProFTPD buffer overflow in mod_rewrite (EUVD-2026-113779) allows remote attackers to overwrite buffers

Status
Unverified: only social posts report this so far
Kind
Vulnerability
Vendor
ProFTPD
Product
ProFTPD
First seen

Summary

The EU Vulnerability Database entry EUVD-2026-113779, scored 6.3 under CVSS v3.1, describes a buffer overflow in ProFTPD's mod_rewrite int:utf8trans RewriteMap. The entry says remote attackers can send long FTP command arguments to overwrite static buffers.

If you use ProFTPD

Upgrade ProFTPD to 1.3.9e or 1.3.10rc5 or later

Disable mod_rewrite RewriteMap rules if you cannot upgrade immediately

Limit FTP access to trusted networks

Review Limit WRITE settings and SFTP user permissions

Audit recently created files in writable SFTP directories

Upgrade ProFTPD to a fixed release beyond 1.3.9e and 1.3.10rc4

What the sources say 3

· Mastodon: “ProFTPD through 1.3.9e and 1.3.10rc1 through 1.3.10rc4 contains a link-following vulnerability in mod_copy that allows authenticated FTP users to bypass Limit WRITE restrictions via symlinks.” Source

· Mastodon: “ProFTPD before 1.3.9e and 1.3.10rc5 contains an authorization bypass in the mod_sftp copy-file extension handler that skips Limit WRITE checks for new destination files.” Source

· Mastodon: “ProFTPD before 1.3.9e and 1.3.10rc5 contains a buffer overflow vulnerability in the mod_rewrite int:utf8trans RewriteMap that allows remote attackers to overwrite static buffers.” Source