GHSA-W466-2WFC-8G58
Open WebUI has vulnerable dependency on starlette via fastapi
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- The rating the maker of the software gives it. Shown when it differs from the CVSS level.What do these mean? →
- High (ghsa)
- Fix
- Fixed in 0.5.8
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Open WebUI, an open-source web interface for AI models, is affected because it relies on a vulnerable version of the Starlette package through its FastAPI dependency. An attacker could potentially exhaust the server's memory and cause a denial of service.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
In version 0.3.32 of open-webui, the application uses a vulnerable version of the starlette package through its dependency on fastapi. The starlette package versions <=0.49 are susceptible to uncontrolled resource consumption, which can be exploited to cause a denial of service through memory exhaustion. This issue is addressed in fastapi version 0.115.3.
Timeline
- Advisory published
- Record last updated
Affected versions
- open-webuiPyPI
fixed in 0.5.8