Skip to main content
← Vulnerabilities

WordPress Product Filter by WBW plugin <= 3.4.6 - SQL Injection vulnerability

9.3CriticalCNA
Exploited
No known exploitation
Fix
Fixed in 3.4.7
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 3.4.7.

Published
Last modified
1.16% · 67th percentile
39/100
Unclear
1 proof of concept on GitHub, 1 Nuclei template
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

The Product Filter by WBW plugin for WordPress, which is used to add product filtering to WooCommerce stores, is affected by this vulnerability. An attacker could exploit it to inject database commands through blind SQL injection, potentially allowing them to read or manipulate data stored in the site's database.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

Read the original description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in WPFactory Product Filter by WBW woo-product-filter allows Blind SQL Injection.This issue affects Product Filter by WBW: from n/a through 3.4.6.

cve.now Index

39cve.now Index 39 of 100 · methodology v3
  • Exploitation10/40Nuclei detection template published
  • Exposure20/25No login or user action needed, CISA rates it automatable · Unknown: Advisories don't say whether default setups are affected
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity9.3/10CVSS 9.3
  • No patch0/5No signal

What would change the score

  • Would score about 74 if added to CISA KEV
  • Would score about 69 if CISA's SSVC rates exploitation active
  • Would score about 44 if advisories confirm default setups are exposed

What to do

  • Upgrade to a fixed version: 3.4.7.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  4. Record last updated

Affected versions

  • woo-product-filter

    through 3.4.6

Evidence 3

  1. Exploit
  2. Exploit
  3. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-112866

Is CVE-2026-112866 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The plugin does not properly sanitize input before passing it to database queries, so an attacker can inject SQL commands. Per the advisory, this could let an attacker read, modify, or delete the entire database, including user accounts and private data.Source: patchstack.com

Which versions are affected by CVE-2026-112866?

woo-product-filter: through 3.4.6.Source: cve.now feed data

Am I affected, and how do I check?

Product Filter by WBW (WordPress plugin woo-product-filter) version 3.4.6 and earlier are affected. To check, look at the plugin version shown on the WordPress Plugins screen or in the plugin's main file header.Source: patchstack.com

How do I fix CVE-2026-112866?

Update the Product Filter by WBW plugin to version 3.4.7 or later, as the advisory directs.Source: patchstack.com