CVE-2026-94624PYSEC-2026-4006GHSA-FRVG-QW88-HWW9
vLLM through 0.29.0 Denial of Service via Unbounded P2P KV Offloading Sessions
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 0.32.0, 0.30.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
vLLM through 0.29.0 contains a denial of service vulnerability in P2P KV offloading when OffloadingConnector is configured with TieringOffloadingSpec and a peer-to-peer secondary tier. Attackers can supply arbitrary remote host and port values in kv_transfer_params to create unreachable peer sessions that retain ZeroMQ sockets until the context quota is exhausted, causing an uncaught ZMQError that crashes EngineCore and stops all inference.
Timeline
- CVE published
- Record last updated
Affected versions
- vllm-project vllm
through 0.29.0
- vllmPyPI
fixed in 0.32.0
- vllmPyPI
fixed in 0.30.0